File Actions

 

File Menu

The complete file action menu looks like the picture below, you can get this menu by clicking on the File menu in the main window, or by right clicking selected files.

 

Selecting files or folders.

You can select one file or one folder by just clicking on it. You can also hold the CONTROL, or Shift, keys while clicking to selected more then one file or folder. The last way to select items is to use the Select menu under the File menu. Under the select menu you can choose to select all files and folder (All), all files (Files), or all folders (Folders). You also have the option Pattern. This will bring up a dialog where you can use WildCard patterns to select items.

Cutting, copying, and Pasting files or folders

 
    
 
   (Cut, Copy, Paste)

To Cut, Copy and Paste find the files you want to Copy or Cut, select them, click the Cut or Copy button. This puts the files in a clipboard. Now find where you want to Paste them (note: you can't Paste to the same FTP connection you Cut or Copy from) and click the Paste button. You can also Drag and Drop between FTP connections. You can setup Max-FTP to Cut when your drop items, or Copy when you drop items in your Options. The first time you use Drag and Drop it will prompt you on whether you want to Cut or Copy the items. The option can also be set in your Options, under the Setup menu.

Deleting files or folders

To delete a file, simply select the files and click the Delete button.

Creating folders

To create a new folder click the New Folder button, a new folder will appear named "New Folder 1". Clicking the button again will create "New Folder 2". After creating a folder you can rename it. (Described Below)

Renaming files or folders

To rename a file you can click it once. Then right click, and click on Rename in the menu that pops up. This will invoke the rename box in the list as shown in the above picture. Then you just type in the name you want. You can also invoke this box by clicking on the item a second time, but not as fast as a double click. When you rename a folder you can leave or take out the slash, it will rename correctly either way.

Opening files or folders

To open files or folders simply double click on the item. You can also use the right button on selected files and click Open under the menu that pops up. You can open up multiple files, but only one folder can be opened at one time.

Refreshing a listing

Click the refresh button to get a fresh listing of the files and folders of a given address, specified in the AddressBar. Refresh is also in the file menus.

Aborting any action

Click the abort button to abort any action Max-FTP is performing on the given FTP connection. Abort is also in the file menus.